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LESSON SKILL MATRIX

 Skill Exam Objective Objective Number

 Formatting, Creating, and Use a theme to apply formatting. 3.2.1
  Customizing a Theme Customize a theme. 3.2.2

 Using Quick Parts in a Document Add built-in building blocks. 3.3.1

 Formatting a Document’s Background Set a colored background. 3.4.2
  Format a document’s background. 3.4.1
  Add a watermark. 3.4.3
  Set page borders. 3.4.4

 Creating and Modifying Headers Insert page numbers. 3.5.1
  and Footers Format page numbers. 3.5.2
  Insert the current date and time. 3.5.3
  Insert a built-in header or footer. 3.5.4
  Apply a different fi rst page attribute. 3.5.8
  Add content to a header or footer. 3.5.5
  Change margins. 3.5.7
  Delete a header or footer. 3.5.6

KEY TERMS
• building blocks

• content controls

• document theme

• fi elds

• footer

• header

• watermarks

Working with Themes, Quick Parts, 
Page Backgrounds, and Headers 

and Footers 7
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 164 Lesson 7

You are a content manager for Flatland Hosting Company, a position in which you 

are responsible for writing and editing all client material, such as hosting guidelines 

and agreements. When creating and revising documents, several Word commands 

can help you work more effi ciently. In this lesson, you learn to apply a theme to a 

document, add content to a document using quick parts, and insert page numbers, 

headers, and footers.

FORMATTING, CREATING, AND CUSTOMIZING A THEME
Word provides features such as themes and Quick Parts to produce creative and professional 
documents. In this lesson, you learn to change the appearance of the document using the exist-
ing and customized themes and inserting building blocks in the document.

Formatting a Document with a Theme
Predefi ned formatting preferences allow you to change the overall appearance of the document 
by selecting and applying a theme. A document theme is a set of predefi ned formatting op-
tions that includes theme colors, fonts, and effects. You can apply one of the preexisting themes 
or create and customize a theme. Document themes contain the following elements: theme 
colors, theme fonts, and theme effects. In this exercise, you learn how to apply a document 
theme in Word.

Theme colors contain four text and background colors, six accent colors, and two hyperlink 
colors. Click the Theme Colors button to change the colors for the current theme, as shown in 
Figure 7-1.

The Bottom Line

Figure 7-1

Theme Colors menu

Theme fonts contain a heading font and a body text font. Click the Theme Fonts button to 
change the fonts for the current theme, as shown in Figure 7-2.
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 Working with Themes, Quick Parts, Page Backgrounds, and Headers and Footers 165

Theme effects are sets of lines and fi ll effects. Click the Theme Effects button to change the ef-
fects for the current theme, as shown in Figure 7-3.

Figure 7-2

Theme Fonts menu

Figure 7-3

Theme Effects menu
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 166 Lesson 7

STEP BY STEP Format a Document with a Theme

OPEN the hosting document from the data fi les for this lesson.

1. On the Page Layout tab, in the Themes group, click Themes; the Themes menu opens, 
as shown in Figure 7-4.

WileyPLUS Extra! features an 
online tutorial of this task.

The hosting
document for this lesson 
is available on the book 
companion website or in 
WileyPLUS.

2. Place your insertion point over any built-in theme and notice that the document 
changes to display a live preview of your document.

Figure 7-4

Document Themes menu

Applying a theme changes the overall design of the entire document.Take Note

3. Click the Grid theme and the elements are applied to the document.

4. SAVE the document as hosting_term in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

3.2.1

How do you apply a theme
to a document?

Creating and Customizing a Theme
In a business environment, the company may want to show consistency by customizing a theme 
to be used for reports throughout the organization. In this exercise, you create, customize, and 
apply a new theme to a document.

STEP BY STEP Create and Customize a Theme

USE the document that is open from the previous exercise.

1. In the Themes group, click the Theme Colors button to open the Colors menu (refer 
to Figure 7-1). The Theme Colors contain predefi ned formatting colors with text and 
background colors, six accent colors, and two hyperlink colors. These colors can be 
customized and saved with a new name.

2. At the bottom of the Colors menu, click Create New Theme Colors; the Create New 
Theme Colors dialog box opens (see Figure 7-5).
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Figure 7-5

Create New Theme Colors 
dialog box

Define a new 
custom name.

Preview your 
selection before 
saving.

Four Text/Background 
and Accent colors  

Hyperlinks is a link to 
a document or a web 

Resets back to 
default colors

There are 12 settings for each color 
set—the defaults are displayed. 

 3. In the Name text box, replace Custom 1 by keying Corporate_[your initials]. Click Save; 
the dialog box closes and you have defi ned a new custom theme color name based on 
default colors.

 4. Click Colors and under the Custom section place your insertion point over Corporate_
[your initials]. Right-click this theme name, then click Edit from the pop-up menu that 
appears. The Edit Theme Colors dialog box appears.

 5. In the list of theme colors, click the Accent 2 drop-down arrow to produce a menu of 
colors for this element. In the fourth column of the menu’s sixth row select Tan, Text 2, 
Darker 50%. Click Save. You changed the default color to a specifi c color and created 
your own custom theme colors for your document.

 6. Click the Fonts button to produce the Theme Fonts menu (refer to Figure 7-2). In the 
menu, click Create New Theme Fonts; the Create New Theme Fonts dialog box opens. 
In the Name text box, replace Custom 1 by keying CorporateFonts_[your initials].

 7. Change the Heading Font and Body Font to Arial; notice the preview of your font 
choices that appears in the Sample pane of the dialog box. Click Save to close the 
dialog box and apply your font choices to the document.

 Another Way
 You can edit the 
Colors and Fonts in the Styles 
group, under Change Styles.

A quick way to change fonts is by keying the font name.Take Note

Figure 7-6

Sample Bevel Shape
with Theme Effects

Applying one of the 
Theme Effects produces 
a different effect on the 
bevel shape.

 9. SAVE the document as hosting_term1 in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

 8. Click the Effects button and select Concourse from the menu that appears (refer to 
Figure 7-3). When applying shapes to your document, such as a bevel shape, the shape 
will display based on the effect you selected. Notice the change in the bevel shape on 
page one by the second paragraph under the heading Introduction (see Figure 7-6).

3.2.2

How do you customize a theme?

Throughout this chapter you will see information that appears in black text within brackets, such 
as [Press Enter], or [your email address]. The information contained in the brackets is  intended to 
be directions for you rather than something you actually type word-for-word. It will instruct you 
to perform an action or substitute text. Do not type the actual text that  appears within brackets.

Take Note
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 168 Lesson 7

Document themes are the same throughout all Offi ce programs and can share the same ap-
pearance.

Take Note

NEW
to Offi ce 2010

USING QUICK PARTS IN A DOCUMENT
Building blocks are organized in galleries and sorted by category. In the Building Block gallery, 
you can insert cover pages, headers, footers, page numbers, text boxes, and watermarks. Another 
term for building blocks is AutoText, and both features are used the same way. In this exercise, 
you learn to use built-in building blocks and insert fi elds in a document.

Using Built-In Building Blocks
Building blocks contain several built-in reusable content such as text, graphics, and objects. 
Building blocks are easily managed and inserted in a document for a quick format.

The Bottom Line

STEP BY STEP Use Built-In Building Blocks

 USE the document that is open from the previous exercise.

 1. On the Insert tab, in the Text group, click the Quick Parts button to display the Quick 
Parts menu, as shown in Figure 7-7.

Figure 7-7

Quick Parts menu

2. Click the Building Blocks Organizer menu option to display the Building Blocks 
Organizer dialog box, as shown in Figure 7-8. In the left pane of the dialog box, the 
preformatted elements or building blocks are listed by name; the Gallery column 
indicates the gallery that contains each building block, and the Category column 
indicates each element’s general type, while the Template column indicates within 
which template the element is stored. You can use the buttons at the bottom of 
the dialog box to delete and edit selected building blocks. The right pane previews 
your selections.

3. Click the Name heading to sort the building blocks by name.

4. Scroll down the list and select Confi dential 1 Watermark.

Troubleshooting You can adjust the Name column by dragging the resize bar to the right to change the 
width.

5. Click the Insert button. The Confi dential watermark appears behind the text on every 
page.

6. Display the Building Blocks Organizer dialog box. Click the Gallery heading to sort the 
building blocks by gallery.

7. Scroll down and select the Austin Pull Quote from the Text Box gallery. Click Insert and 
pull quote is inserted in the document as shown in Figure 7-9. You can key text in the 
placeholders or drag and drop text in the area.

3.3.1

How do you insert a quote in 
a document using the Building 

Blocks Organizer?
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 Working with Themes, Quick Parts, Page Backgrounds, and Headers and Footers 169

Easily sort list by column heading

Building blocks 
are a collection 
of templates and 
stored as such. 

Removes the selected 
building block name 
from the gallery.

Inserts the building 
block in the document

Preview selected 
building block

A brief description of 
the building block

Figure 7-8

Building Blocks Organizer

Figure 7-9

Document with text 
box pull quote

Place pointer on hyphenated 
lines around text box to drag 
and drop to the end of first 
paragraph.
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 170 Lesson 7

8. Under the heading, Introduction, select the second paragraph beginning with 
“Questions or comments. . . .” Move the selected text inside the quote area by 
dragging and dropping. Delete the line break and one paragraph mark after the fi rst 
paragraph under Introduction.

9. Place your pointer on the hyphenated lines around the quote text box—the pointer 
changes to four arrows to allow you to drag and drop. Drag the quote to the end of the 
fi rst paragraph until it wraps around the last seven lines of the paragraph.

Troubleshooting Deselect the text box and select again to see the hyphenated lines around the text box.

10.  Select the Bevel shape—the pointer changes to four arrows to allow you to drag to 
a new location. Drag the Bevel shape by the quote text box on the right margin (see 
Figure 7-10).

Figure 7-10

Document with text box pull
 quote wrapped around 

 paragraph with bevel shape

11. Click outside the Bevel shape and press Ctrl+End to move the insertion point to the 
end of the document.

12. Display the Building Blocks Organizer dialog box. Scroll down and select Alphabet 
Sidebar from the Text Box Gallery. Click Insert. The text box is inserted at the end of the 
document and positioned on the left side of the document. Your next step is to insert 
text into the text box.

13. When selecting the paragraph, do not select the paragraph mark; this will avoid 
displaying the horizontal line in the Text Box twice. Select the paragraph above Refusal 
of Service beginning with “You and Flatland Hosting further agree . . .” and drag and 
drop the selection in the text box. Delete the two paragraph marks above the heading, 
Refusal of Service.

14. Click the Building Blocks Organizer to display the dialog box and select Austin in the 
Headers Gallery. Click Insert. A header with a border is inserted in every page of the 
document.

15. Select the text in the placeholder, Type the document title and key Flatland Hosting 
Company in the Header placeholder. Click the Close Header and Footer button located 
on the Header & Footer Tools Design tab. Inserting a header from the Building Block 
will automatically display the Header & Footer Tools tab.

16. Click the Building Blocks Organizer to display the dialog box and select Conservative 
in the Footers Gallery. Click Insert. A footer is inserted in every page of the document 
with the page number displayed.

17. Click the Close Header and Footer button from the Header & Footer Tools Design tab.

3.3.1

How do you insert a building 
block text box using the 

Building Blocks Organizer?

3.3.1

How do you insert a header or 
footer in a document using the 

Building Blocks Organizer?

3.3.1

How do you insert a cover 
page using the Building Blocks 

Organizer?
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 Working with Themes, Quick Parts, Page Backgrounds, and Headers and Footers 171

18. Click the Building Blocks Organizer to display the dialog box and select Austin in the 
Cover Page Gallery. Click Insert. The cover page is inserted as page 1.

19. Key the following information in the placeholders:

  Abstract: Flatland Hosting Company will set guidelines and requirements for use of 
Flatland Hosting services.

  Document Title: Flatland Hosting Company automatically appears

  Subtitle: Guidelines & Agreements

  Type the Author Name: A. Becker

20. SAVE the document as hosting_term2 in your USB fl ash drive in the lesson folder and 
CLOSE the fi le.

PAUSE. LEAVE Word open to use in the next exercise.

3.3.1

How do you insert a 
watermark using the Building 

Blocks Organizer?

Troubleshooting If you experience problems in saving the author’s name, complete one of the following 
actions: (1) Click the File tab, then Options. In the General category, under Personalize 
your copy of Microsoft Offi ce section, key the author’s name by the User name box and 
initials. Changing the User Name will be discussed in Lesson 9; (2) Click the File tab and in 
the section Prepare for Sharing, click the Allow this information to be saved in your fi le link
and then save. Prepare for Sharing will be discussed in Lesson 13.

 Another Way
 On the Insert tab, 
in the Pages group, click the 
Cover Page button to insert a 
cover page.

 Another Way
 In the Header & 
Footer group, you can insert 
a header or footer or page 
number.

Later in this lesson, you will learn to insert a watermark in the Page Background group.Ref 

Inserting an Equation
Microsoft Word 2010 has built-in equations, which can be inserted from the Quick Parts gallery 
or using the Equations command. You can use the Equation Tool Design tab, which displays 
when an equation is inserted in a document, to edit or construct your own equation. In this 
exercise, you learn to insert equations in a document.

STEP BY STEP Insert an Equation

OPEN a new blank Word document.

1. Click the Insert Tab and, in the Text group, click the Quick Parts button then click the 
Building Blocks Organizer.

2. In the Building Block Organizer dialog box, locate and click the Expansion of a Sum 
equation in the Equation Gallery. Click Insert. The Expansion of a Sum equation 
is inserted in the document. Position the insertion point after the equation 
placeholder and then press the Enter key twice to place a blank line below the 
placeholder.

3. In the Building Block Organizer dialog box, locate and click the Area of Circle equation, 
then click Insert. Position the insertion point after the equation placeholder and then 
press the Enter key twice to place a blank line below the placeholder.

4. In the Building Block Organizer dialog box, locate and click the Binomial Theorem 
equation. Click Insert. Click outside the equation placeholder, and press the Enter key 
twice.

5. SAVE the document as equations in your USB fl ash drive in the lesson folder and 
CLOSE.

PAUSE. LEAVE Word open to use in the next exercise.

3.3.1

How do you add an equation 
to a document using the 

Building Blocks Organizer?

 Another Way
 In the Insert 
tab, Symbols group, click the 
Equation button and select an 
equation from the built-in menu.
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 172 Lesson 7

Inserting a Field from Quick Parts
A fi eld is a placeholder where Word inserts content in a document. Word automatically uses 
fi elds when specifi c commands are activated, such as those for inserting dates, page numbers, 
and a table of contents. When you insert a date fi eld in a document, the date will be updated 
automatically each time the document is opened. In this exercise, you learn to insert a fi eld in 
a document.

Fields, also called fi eld codes, appear between curly brackets ({ }) when displayed. Field codes are 
turned off by default. To display fi eld codes in a document, press Alt+F9. To edit a fi eld, place 
the insertion point within the fi eld and right-click and then click Edit Field.

STEP BY STEP Insert a Field from Quick Parts

OPEN the hosting_term2 document from the lesson folder.

1. Press Ctrl+End to move to the end of the document. The insertion point is positioned 
on the last paragraph mark.

2. Key Last Updated: in bold and press the spacebar once after the colon.

3. On the Insert tab, in the Text group, click the Quick Parts button.

4. Click Field on the menu. The Field dialog box is displayed (see Figure 7-11).

          The hosting_term2 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

Select category by 
clicking drop-down arrow.

Available 
Field options

Date formats

Figure 7-11

Field dialog box

5. From the Categories drop-down list, click Date and Time.

6. In the Field Names list, click Date.

7. In the Date Formats list, select the ninth option with the Day Month Year format and 
click OK to close the dialog box and insert the date and time fi eld in your document. 
The document should look similar to the one shown in Figure 7-12, with the exception 
that the current date will appear.

8. SAVE document as hosting_term3 in your USB fl ash drive in the lesson folder and 
CLOSE.

PAUSE. LEAVE Word open to use in the next exercise.

 Another Way
 On the Insert tab, 
in the Text group, click Date 
& Time to open the Date and 
Time dialog box.
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FORMATTING A DOCUMENT’S BACKGROUND
Word’s enhanced features allow the user to produce a creatively formatted document by chang-
ing the background color, inserting a watermark, and adding a border to the document.

Inserting a Page Color
Adding a background color to the title page of a report conveys originality. You may want to dis-
tinguish your research paper from others, for example, by adding a background color to the fi rst 
page. It is important to use background colors in moderation and to choose a page color that 
will not interfere with the text. If text is dark, for example, then the background color should be 
light, and if text is light, a dark background would improve the document’s readability. In this 
exercise, you learn to insert a page color in a document.

Figure 7-12

Document with Date fi eld 
inserted

The Bottom Line

WileyPLUS Extra! features an 
online tutorial of this task.

3.4.2

How do you add a page color 
to a document?

STEP BY STEP Insert a Page Color

OPEN hosting_term from your USB fl ash drive for this lesson.

 1. Click the Page Layout tab.

 2. In the Page Background group, click the Page Color button to open the color menu and 
gallery, as shown in Figure 7-13. Click to select White, Background 1, Darker 5%; the 
page color is applied.

 3. SAVE the document as hosting_term4 in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

 The hosting_term 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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 174 Lesson 7

Formatting the Page Color Background
You can apply formatting to a page color background with one color or fi ll effect, such as, 
gradient, texture, pattern, or a picture. A gradient fi ll is a shape fi ll that changes from one color 
to another based on the shading style selected. You can select from one color or two to preset 
colors. The layout of the page colors provides emphasis to the document. In this exercise, you 
learn to format the page background using two colors and changing the shading style.

Figure 7-13

Page Color menu

STEP BY STEP Format the Page Color Background

USE the document that is open from the previous exercise.

1. With the Page Layout tab active, click the Page Color button, and in the menu that 
appears, click Fill Effects. The Fill Effects dialog opens with the Gradient tab active.

 2. Under the Colors section, select Preset and then click the drop-down arrow under the 
Preset colors section to view available background colors.

3. In the Gradient tab under the Colors section, select Two colors. Two options appear, 
Color 1 and Color 2. Under Color 2 click the drop-down arrow to produce the color 
palette. In the ninth column third row, select Brown, Accent 5, Lighter 60%. The 
selected color appears in the box under Color 2 (see Figure 7-14).

Figure 7-14

Fill Effects dialog box
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4. Under the Variants section, samples of the two colors are displayed. Under the 
Shading Styles section, you have choices on how the style should appear in the 
document. Select From Center. Notice the lower-right corner produces Color 1 in the 
center and Color 2 outside. Click OK.

 5. SAVE the document as hosting_term5 in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Adding a Watermark
In business, some documents may contain sensitive information, and the nature of a document’s 
status should be clearly conveyed on its pages. Word provides built-in text, called watermarks, 
that display lightly behind text as words, such as, confi dential, draft, or urgent. Watermarks can 
be customized to include text or images, including company logos. In this lesson, you learn to 
customize a watermark and insert it into a document.

3.4.1

How do you format a page 
color background?

STEP BY STEP Add a Watermark

USE the document that is open from the previous exercise.

1. In the Page Background group of the Page Layout tab, click the Watermark menu and 
scroll down to select Custom Watermark. The Printed Watermark dialog box opens. 
Select the Text watermark radio button and then click the drop-down arrow next to 
Text and select Draft. You can customize text watermarks by keying content in the text 
box or you can select from the drop-down menu.

 2. Click the drop-down arrow by Font and select Calibri. This will change the text 
watermark font.

 3. In the Color text box click the drop-down arrow and select Gray-50%, Accent 6 in the 
Theme Colors (see Figure 7-15).

Figure 7-15

Printed Watermark dialog box

4. Click OK. The watermark is inserted on all pages. Note, if you click Apply, the dialog 
box remains open and you can view your watermark in the document. When you click 
OK, the dialog box closes and you’re back in the document screen.

5. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

3.4.3

How do you add a 
watermark to all pages

in a document?

Earlier in this lesson, you learned to insert a watermark using the Building Blocks Organizer.Ref 
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 176 Lesson 7

Adding a Page Border
The Page Borders command allows you to insert a border around a document’s page. Adding a 
border adds to the page or frame of a page and improves the appearance of the document. Ap-
plying elements by changing the color, width, and style adds emphasis to the page. In this lesson, 
you learn to add elements to a page border and insert them into a document.

STEP BY STEP Add a Page Border

USE the document that is open from the previous exercise.

1. In the Page Background group of the Page Layout tab, click the Page Borders button. 
The Borders and Shading dialog box appears.

2. In the Setting section, click the Shadow option. Notice the lower-right bottom has a 
shadow effect to the border.

3. Click the drop-down arrow on the Color menu and in the ninth column, fi rst row 
choose Brown, Accent 5. You are applying a specifi c color to the border.

 4. Click the drop-down arrow on the Width menu and choose 2 1/4 pt. The width of the 
border is increased to provide emphasis.

 5. Click the drop-down arrow on the Apply To menu and click This section–First page only
as shown in Figure 7-16. The page border is applied to the fi rst page only.

Border lines styles can give a 
document a different appearance. Allows you to 

preview before 
confirming 
your selection

A specific color can 
be applied to borders.

Determine where the 
border will be applied 
in the document.

Change the weight of 
the border by selecting 
one of the options.

Setting contains 
five options.

Figure 7-16

Borders and Shading
dialog box

6. Click OK. Scroll and review your document and notice that the border does not appear 
on other pages.

7. Select the bevel shape on page 1 and press Delete.

8. SAVE the document as hosting_term6 to your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

3.4.4

How do you add a page 
border to a document?
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CREATING AND MODIFYING HEADERS AND FOOTERS
A header appears on the top of a page and a footer appears at the bottom of the document’s 
page. The Header & Footer group contains commands for inserting built-in headers, footers, 
and page numbers into a Word document.

The Page Number button in the Header & Footer group has commands for inserting page num-
bers at the top, bottom, or in the margin of a page using the built-in gallery. In this exercise, you 
learn to insert page numbers in a document.

Adding Page Numbers
USE the document that is open from the previous exercise.

 1. Place the insertion point anywhere on the fi rst page.

 2. Click the Insert tab.

 3. In the Header & Footer group, click the Page Number button, and in the menu that 
appears, point to Bottom of Page; in the pull-down menu, select Plain Number 2, as 
shown in Figure 7-17. Page numbers are inserted on all pages. Notice that the Headers 
& Footer Tools opens with the Design tab active.

The Bottom Line

Figure 7-17

Page Number menu

 4. In the Design tab, in the Close group, click the Close Header and Footer button. The 
Header & Footer Tools closes.

 5. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

3.5.1

How do you add page 
numbers to every page?
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Formatting Page Numbers
Word provides various types of numbering formats to choose from, such as, 1, 2, 3 . . .; i, ii, iii . . .; 
or a, b, c. . . . In addition to choosing a numbering style, Word’s page number formatting commands 
enable you to decide where page numbering will begin, pause, and continue. In this exercise, you 
learn to change the page number format.

STEP BY STEP Format Page Numbers

USE the document that is open from the previous exercise.

1. In the Headers & Footers group in the Insert tab, click the Page Number button to 
display the menu.

2. Click Format Page Numbers. The Page Number Format dialog box appears.

 3. In the Number Format text box, click the drop-down arrow and select the lowercase 
roman numerals option (i, ii, iii, . . .) as shown in Figure 7-18. Selecting this option will 
change the number format to lowercase Roman numerals on all pages.

Figure 7-18

Page Number Format
dialog box

Click drop-down arrow 
to select format.

4. Click OK.

5. SAVE the document as hosting_update in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Removing Page Numbers
The Remove Page Numbers command will remove all page numbering in the document. In this 
exercise, you will remove all page numbers from the document.

3.5.2

How do you format page 
numbers?

 Another Way
 Scroll down to 
the fi rst footer on page 1 and 
double-click on the footer; the 
Header & Footer Tools display. 
Click Page Number and then 
Format Page Numbers to open 
the Page Number Format 
dialog box.

STEP BY STEP Remove Page Numbers

USE the document that is open from the previous exercise.

1. In the Headers & Footers group in the Insert tab, click the Page Number button to 
display the menu.

2. Click Remove Page Numbers. All page numbers are removed from the document.

3. Click Undo to restore all page numbers.

4. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.
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Inserting the Current Date and Time
Word’s Insert tab contains a number of command groups that enable you to insert charts, graphs, 
images, and other elements into Word documents. In this exercise, you learn to use commands 
in the Insert tab to insert the date in a document.

STEP BY STEP Insert Current Date and Time

USE the document that is open from the previous exercise.

1. Position the insertion point in the third line on page 1, under the heading. Key Date 
Submitted: and press the spacebar once after the colon.

 2. In the Text group, in the Insert Tab, click Date & Time. The Date and Time dialog box 
opens, as shown in Figure 7-19.

Figure 7-19

Date and Time dialog box

Available 
format 
options

Automatically updates 
document with current 
date when selected

3. In the Available Formats list, select the ninth option, which displays the Day Month 
Year date format. Click OK. The selected format with the current date is inserted in the 
document.

 4. Press Ctrl+End. The insertion point is on the last paragraph mark. Key Time Submitted: 
and press the spacebar once after the colon.

5. Click the Date & Time command, and in the Date and Time menu that appears, select 
the fourth option from the bottom of the Available Formats list, which displays time in 
hours and minutes, using the 12-hour clock format.

6. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Inserting a Built-In Header or Footer
The Header and Footer commands provide options for inserting content at the top and bottom 
of pages and enable you to edit, remove, save, and view additional headers and footers online. 
You can choose to make the fi rst page header and/or footer different from those on subsequent 
pages and place these elements on odd or even pages only using the Headers and Footers tools 
from the Design tab that appears when you insert one of these elements into your document. In 
this exercise, you learn to insert a built-in header and footer.

3.5.3

How do you insert the current 
date and time in a document?

Earlier in this lesson, you learned how to insert headers and footers using Quick Parts.Ref 
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2. In the Options group of the Header & Footer Design tab, shown in Figure 7-21, click the 
Different First Page box. In the Navigation group, click Previous to go to the fi rst page 
and notice the header is removed from the fi rst page.

STEP BY STEP Insert a Built-In Header or Footer

USE the document that is open from the previous exercise.

1. In the Header & Footer group in the Insert tab, click the Header button, and in the 
drop-down menu that appears, scroll down to select the Pinstripes option, as shown 
in Figure 7-20. The header is inserted on every page and the Header & Footer Design 
tab opens.

Figure 7-20

Header menu

3.5.4

How do you insert a built-in 
header or footer?

Figure 7-21

Header & Footer Tools

Takes you to the preceding 
header or footer

Advances to the next 
header or footer

Options group allows you to turn off 
the page number, header, or footer.

Footer from Bottom is the 
distance from the bottom margin.

Header from Top is the distance 
from the top margin.

3. In the Navigation group, click Next to go to the header area of page 2.

4. In the Header & Footer group, click the Footer button and scroll down to click Pinstripes 
from the menu that appears. Notice the new footer inserts the word Page by the 
formatted page number that you inserted in a previous exercise (see Figure 7-22).
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 5. Click the Close Header and Footer button on the Design tab.

 6. SAVE the document as hosting_update1 in your USB fl ash drive in lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Adding Content to a Header or Footer
Content controls are individual programs that allow you to add information in a document, 
such as a header or footer. Content controls are used for templates, forms, and documents and 
are identifi ed by a border and temporary text. In this exercise, you learn to add content to a 
placeholder in a header and footer.

Formatted page 
number

Figure 7-22

Footer with formatted
page number

3.5.8

How do you apply a different 
fi rst page?

STEP BY STEP Add Content to a Header or Footer

USE the document that is open from the previous exercise.

 1. Position the insertion point on the second page of the document and double-click the 
header to activate.

 2. The placeholder [Type the document title] is selected.

 3. Key Guidelines and Requirements, as shown in Figure 7-23, to create the text that will 
appear in your document’s header.

 Another Way
 Click the Insert 
tab and in the Header & Footer 
group, click Edit Header.

Content added 
to header

Figure 7-23

Title in header

 4. On the Navigation group on the Design tab, click Go to Footer; the insertion point 
moves to the page ii footer. Click [Type text] and key Flatland Hosting Company to 
replace the placeholder.

 5. Select the text in the footer, including the page number. Display the Mini toolbar 
by right-clicking. Click the drop-down arrow at the Font box and change the Font to 
Arial.

 6. Click the Grow Font button on the Mini toolbar to increase the font size to 12.

 7. Click the Italic button to turn off.

 8. Click the footer to deselect.

 9. Click the Close Header and Footer button on the Design tab to close. The Header & 
Footers Tools Design tab closes.

 10. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Changing the Position of a Header or Footer
The header and footer default location is .5" from the top and bottom margins. The Position 
commands option on the Header & Footer Tools enable you to change this default setting. In 
this exercise, you learn to modify the header and footer position.

3.5.5

How do you add content to a 
header or footer?
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STEP BY STEP Change the Position of a Header or Footer

USE the document that is open from the previous exercise.

1. Point to the header on the second page and double-click to activate the Header & 
Footer tools.

2. In the Position group, in the Header & Footer Design tab, click the Header from Top 
scroll arrow until the measurement in the selection box changes to .2”.

3. In the Position group, click the Footer from Bottom scroll arrow until the measurement 
in the selection box changes to .2”.

4. SAVE the document in your USB fl ash drive in the lesson folder.

PAUSE. LEAVE the document open to use in the next exercise.

Removing a Header or Footer
In this exercise, you learn to use the Remove Header or Footer command to remove all headers 
and footers from the document.

3.5.7

How do you change the 
top and bottom margins for 

headers or footers?

STEP BY STEP Remove a Header or Footer

USE the document that is open from the previous exercise.

1. In the Design tab, in the Header & Footer group, click the Header button and the menu 
appears.

2. Click Remove Header. The headers are removed from the document.

3. To remove all footers in the document, click the Footer button in the Header & Footer 
group. The menu appears.

4. Click Remove Footer and footers are removed from the document.

 5. SAVE and CLOSE the document as hosting_fi nal in your USB fl ash drive in the lesson 
folder.

CLOSE Word.

 Another Way
 Double-click the 
Header or Footer and press 
Delete. This will remove all 
headers or footers.

3.5.6

How do you delete a header 
or footer?

SKILL SUMMARY

In This Lesson,
You Learned How To: Exam Objective Objective Number

Format, create, and Use a theme to apply formatting.  3.2.1
 customize a theme Customize a theme.  3.2.2

Use Quick Parts in Add built-in building blocks.  3.3.1
 a document

Format a document’s Set a colored background  3.4.2
background Format a document’s background.  3.4.1

 Add a watermark.  3.4.3
 Set page borders.  3.4.4

Create and modify Insert page numbers.  3.5.1
 headers and footers Format page numbers.  3.5.2
 Insert the current date and time.  3.5.3
 Insert a built-in header or footer.  3.5.4
 Apply a different fi rst page attribute.  3.5.8
 Add content to a header or footer.  3.5.5
 Change margins.  3.5.7
 Delete a header or footer.  3.5.6
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Knowledge Assessment

True/False
Circle T if the statement is true or F if the statement is false.

  T F  1.  A watermark is a text or graphic printed behind text.

  T F  2.  To edit a header or footer, you must triple-click to activate a header or 
footer.

  T F  3.  The Header & Footer Tools display in the Ribbon after a header or footer 
is inserted.

  T F  4.  Built-in headers and footers provide instant design.

  T F  5.  If you make any changes to the colors, fonts, or effects of the current 
theme, you can save it as a custom version and apply it to future 
documents.

  T F  6.  A picture can be inserted as a page background.

  T F  7.  A header and footer cannot be used in the same document.

  T F  8. You can specify a different header for odd and even pages.

  T F  9.  Page colors are the background color of a page.

  T F 10.  A footer can contain text or graphics.

Multiple Choice
Select the best response for the following statements.

1. Building blocks can be sorted by all EXCEPT which of the following?

a. Name

b. Creator

c. Gallery

d. Category

2. __________ is a new option within the Quick Parts menu.

a. AutoComplete

b. Auto Organizer

c. AutoText Insert

d. AutoText

3. Identify the tiny program that includes a label for instructing you on the type of text to 
include and a placeholder that reserves a place for your new text.

a. Placeholder

b. Fields

c. Content Control

d. All of the above

4. A document theme includes sets of which of the following?

a. Colors

b. Fonts

c. Effects

d. All of the above

e. None of the above

5. A line inserted around the page is called a __________.

a. Document page border

b. Border

c. Page border

d. None of the above
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6. To preview a style or a theme, you must do which of the following?

a. Place your pointer over the choice

b. Print the document

c. Set up the document properties

d. It is not possible to preview a style or theme.

7. The ____________ provides a way to manage building blocks by editing, deleting, and/
or inserting them.

a. Quick Organizer

b. Cover Page

c. Text box

d. Organizer

8. A __________ is a placeholder that tells Word to insert changeable data into a 
document.

a. Field name

b. Field

c. Data fi eld

d. Data source

9. Customized company logos applied to a page background is called a(n)__________.

a. MarkArt

b. Insert picture command

c. Watermark

d. SmartArt

10. In the _____________dialog box, you can specify to insert a page border on only the 
fi rst page of a document.

a. Page Border

b. Borders and Shading

c. Page Border tab

d. Line Border

Competency Assessment

Project 7-1: Elevator Communications
Montgomery, Slade & Parker uses elevator communications for in-house announcements, invitations, 
and other employee relations documents. In each elevator, a durable 81/2” � 14” clear plastic frame 
has been installed in which announcements can be inserted and changed on a regular basis. Create a 
document for approval that recognizes employee award winners and invites employees to a reception 
to honor these award winners.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN congratulations from the data fi les for this lesson and SAVE AS elevator_com in 
your USB fl ash drive in the lesson folder.

 2. In the Page Background group, in the Page Layout tab click the Page Color menu. In 
the Theme Colors section, select Olive Green, Accent 3, Lighter 60%.

 3. Click the Page Borders button. In the Borders and Shading dialog box, click Shadow in 
the Setting section. Click the Width menu and choose 3 pt. In the Color section, select 
Olive Green, Accent 3, Darker 50%. Click OK.

 4. In the Page Setup group in the Page Layout tab, click the Size menu and select Legal.

 5. Launch the Page Setup dialog box and click the Layout tab. In the Page section, change 
the Vertical Alignment to Center.

 6. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

LEAVE Word open for the next project.

The congratulations 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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Project 7-2: Reference Letter
A former employee at Flatland Hosting Company has asked for a reference letter.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN reference_letter from the data fi les for this lesson and SAVE AS jasmine_
reference in your USB fl ash drive in the lesson folder.

 2. In the Page Layout tab, in the Themes group, click Themes and click Origin from the 
gallery menu.

 3. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

LEAVE Word open for the next project.

The reference letter 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

Profi ciency Assessment

Project 7-3: Letterhead
Create a new letterhead for the Flatland Hosting Company.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN a new blank document and SAVE AS FHCletterhead in your USB fl ash drive in 
the lesson folder.

 2. In the Insert tab, in the Header & Footer group, insert the Tiles built-in header and key 
the document title as Flatland Hosting Company. Bold the text and change the size to 
18 pt.

 3. Right-click the Content Control, Year, and click Remove Content Control.

 4. Insert the Tiles built-in footer and key the company address as 1234 Grand Street, 
Forest Grove, OR 97116. Select the page number and press the Delete key. Close the 
Header and Footer.

 5. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

LEAVE Word open for the next project.

Project 7-4:  Two-Page Resume
Your friend Mike has revised and added some information to his resume, and it is now two pages 
long. Update the formatting to include a header and footer.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN mzresume2 from the data fi les for this lesson and SAVE AS mzresume2updated 
in your USB fl ash drive in the lesson folder.

 2. In the Page Layout tab, click the Margins menu and select Custom Margins. In the 
Page Setup dialog box, change the top, bottom, left, and right margins to 1.25”.

 3. Click OK.

 4. In the Insert tab, in the Header & Footer group, click the Header menu and select 
Stacks.

 5. In the header document title, key Resume of Michael J. Zuberi.

 6. In the Options group, click the Different First Page box.

 7. In the Navigation group, click Next. In the Header & Footer group, click the Footer 
button and select Stacks.

 8. Select the Content Control, [Type the Company Name], and right-click and Remove 
Content Control. Close the Header and Footer.

 9. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

LEAVE Word open for the next project.

The mzresume2 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.
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Mastery Assessment

Project 7-5: Postcard
It’s soccer season again, and the YMCA is sending out postcards to all participants who played last 
season.

 GET READY. LAUNCH Word if it is not already running.

 1. OPEN soccer from the data fi les for this lesson and SAVE AS postcard in your USB 
fl ash drive in the lesson folder.

2. Customize the page size to 4” x 6”, the orientation to Landscape, and the margins to 
Narrow.

3. Insert a page border and add a red double-line page border with a box setting and set 
the width to 3/4 pt.

 4. In the Fill Effects dialog box select One Color in the Color 1 section and select Red, 
Accent 2, Lighter 80%. In the Shading styles section, select Diagonal up. Under 
Variants, click the sample horizontal pattern in the lower-right corner.

 5. Add a Custom Watermark in the Text watermark section and replace ASAP with YMCA 
SOCCER. Click the Horizontal button and click OK.

 6. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

LEAVE Word open for the next project.

Project 7-6: Thank-You Card
Create thank-you notes that match the style of Mike’s new two-page resume.

 GET READY. LAUNCH Word if it is not already running.

 1. Create a new blank document and SAVE AS thankyou in your USB fl ash drive in the 
lesson folder.

 2. Customize the page size to 5.5” x 8.5”, leave the orientation at the default, and 
change the margins to narrow. The goal is to format the document appropriately and 
fold the document in the middle so that the text, Thank You, will be on the front of 
the note card.

 3. Refer to the built-in footer used in the mzresume2updated document and insert that 
footer in your current document. In the Content Controls placeholder, key Thank You. 
For consistency, use the same font, size, and style as Michael J. Zuberi’s name on the 
resume.

 4. SAVE the document in your USB fl ash drive in the lesson folder and then CLOSE.

CLOSE Word.

The soccer 
document fi le for this 
lesson is available on the 
book companion website 
or in WileyPLUS.

INTERNET READY

Studies have identifi ed which cities are the “Best Places to 
Live.” Choose one of the top ten and fi nd out why it ranked 
high. Create a promotional document touting the positive 

ranking and listing reasons for the ranking. The document 
could be a fl yer, postcard, or letter that city offi cials could 
mail to prospective businesses and families who request in-
formation about the city.
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CREATING A FLYER AND APPLYING
THEMES AND QUICK PARTS
You are the assistant to two managers at Flatland Hosting Company. They have decided to 
distribute monthly fl yers to all employees on new happenings within the company.

They have asked you to format the monthly fl yer using the new skills you have learned in Word. 
Create a fl yer promoting Internet services to employees at a discounted rate and include security 
and privacy issues. Be innovative; incorporate features such as adding a customized theme, 
 watermark, page color, and page border, and apply an appropriate building block to produce a 
fl yer that will capture employees’ attention. Insert the current date as a footer.

WorkplaceReady
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